[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Request for testers: Video hardware autodetection



Mike A. Harris wrote:
Clyde E. Kunkel wrote:
Mike A. Harris wrote:

The latest xorg-x11-drv-* driver packages contain videoaliases
files for kudzu et al. to use for video card autodetection and
driver mapping.



<snip>

If you have a video card which is assigned the "vesa" driver
from the above test, then it is either not supported by the
drivers, or we're missing a PCI ID to driver mapping for that
card/chip.  To determine if it is supported by the driver,
hand edit the xorg.conf and replace the vesa driver with the
native X driver for the particular vendor.  ie: "nv" for
Nvidia, "ati" for ATI, etc., and test to see if X starts up.

<snip>

2/6/06 rawhide ati driver xorg-x11-drv-ati-6.5.7.3-3 still detects radeon 9200 AGP as vesa. BZ 180001 updated.

This is an odd situation, as it appears as if the videoalias files
are being ignored by kudzu.  The radeon.xinf does contain the entries
for the Radeon 9200, so it should get detected.  Are you running
a fully updated system, including the latest kudzu,
system-config-display, rhpl, rhplx, pyxf86config, all xorg packages,
kernel, etc.?

If one uses an old (FC4 era, or early FC5 rawhide) set of any of these
packages, that would explain it.

To make matters more confusing, other people are claiming the
autodetection does work properly now.  So I'd like to ask everyone
to make absolutely sure their entire system is completely updated
to current rawhide, and not just xorg packages.  Also, systems
running FC4 with some parts of rawhide will totally not work right
as far as autodetection goes, but that is expected.
situation exist
If everyone is updated however, and the problem remains only for
some people, then we'll have to investigate why that's happening,
but it would sure be a strange situation. ;)

Thanks for the update!




what is rhplx?

reran "yum update" and got no updates. Went to another similar system that has a clean install of FC5T2 and yum updated daily (and verified again) and same vesa driver created in xorg.conf. This system has a radeon 9200 AGP AND a radeon 9200 SE PCI.

For the original system (which is, BTW, a FC3 install, updated almost daily from rawhide):

[root P4C800ED ~]# rpm -qa kudzu system-config-display rhpl rhplx pyxf86config kernel-smp xorg* | sort
kernel-smp-2.6.15-1.1878_FC5
kernel-smp-2.6.15-1.1881_FC5
kernel-smp-2.6.15-1.1884_FC5
kernel-smp-2.6.15-1.1895_FC5
kernel-smp-2.6.15-1.1898_FC5
kernel-smp-2.6.15-1.1907_FC5
kernel-smp-2.6.15-1.1909_FC5
kudzu-1.2.24-1
pyxf86config-0.3.22-1
rhpl-0.181-1
system-config-display-1.0.36-1
xorg-x11-apps-1.0.1-1
xorg-x11-drivers-0.99.2-4
xorg-x11-drv-acecad-1.0.0.5-1
xorg-x11-drv-aiptek-1.0.0.5-1
xorg-x11-drv-apm-1.0.1.5-1
xorg-x11-drv-ark-0.5.0.5-1
xorg-x11-drv-ati-6.5.7.3-3
xorg-x11-drv-calcomp-1.0.0.5-1
xorg-x11-drv-chips-1.0.1.3-1
xorg-x11-drv-cirrus-1.0.0.5-1
xorg-x11-drv-citron-2.1.1.5-1
xorg-x11-drv-cyrix-1.0.0.5-1
xorg-x11-drv-digitaledge-1.0.1.3-1
xorg-x11-drv-dmc-1.0.0.5-1
xorg-x11-drv-dummy-0.1.0.5-1
xorg-x11-drv-dynapro-1.0.0.5-1
xorg-x11-drv-elo2300-1.0.0.5-1
xorg-x11-drv-elographics-1.0.0.5-1
xorg-x11-drv-evdev-1.0.0.5-1
xorg-x11-drv-fbdev-0.1.0.5-1
xorg-x11-drv-fpit-1.0.0.5-1
xorg-x11-drv-glint-1.0.1.3-1
xorg-x11-drv-hyperpen-1.0.0.5-1
xorg-x11-drv-i128-1.1.0.5-1
xorg-x11-drv-i740-1.0.0.5-1
xorg-x11-drv-i810-1.4.1.3-3
xorg-x11-drv-jamstudio-1.0.0.5-1
xorg-x11-drv-joystick-1.0.0.5-1
xorg-x11-drv-keyboard-1.0.1.3-1
xorg-x11-drv-magellan-1.0.0.5-1
xorg-x11-drv-magictouch-1.0.0.5-1
xorg-x11-drv-mga-1.2.1.3-1
xorg-x11-drv-microtouch-1.0.0.5-1
xorg-x11-drv-mouse-1.0.3.1-1
xorg-x11-drv-mutouch-1.0.0.5-1
xorg-x11-drv-neomagic-1.0.0.5-1
xorg-x11-drv-nsc-2.7.6.5-2
xorg-x11-drv-nv-1.0.1.5-1
xorg-x11-drv-palmax-1.0.0.5-1
xorg-x11-drv-penmount-1.0.0.5-1
xorg-x11-drv-rendition-4.0.1.3-1
xorg-x11-drv-s3-0.3.5.5-1
xorg-x11-drv-s3virge-1.8.6.5-1
xorg-x11-drv-savage-2.0.2.3-1
xorg-x11-drv-siliconmotion-1.3.1.5-1
xorg-x11-drv-sis-0.8.1.3-1
xorg-x11-drv-sisusb-0.7.1.3-1
xorg-x11-drv-spaceorb-1.0.0.5-1
xorg-x11-drv-summa-1.0.0.5-1
xorg-x11-drv-tdfx-1.1.1.3-1
xorg-x11-drv-trident-1.0.1.2-1
xorg-x11-drv-tseng-1.0.0.5-1
xorg-x11-drv-ur98-1.0.0.5-1
xorg-x11-drv-vesa-1.0.1.3-1
xorg-x11-drv-vga-4.0.0.5-1
xorg-x11-drv-via-0.1.33.2-1
xorg-x11-drv-vmware-10.11.1.3-1
xorg-x11-drv-void-1.0.0.5-1
xorg-x11-drv-voodoo-1.0.0.5-1
xorg-x11-filesystem-0.99.2-3
xorg-x11-fonts-100dpi-7.0-1
xorg-x11-fonts-75dpi-7.0-1
xorg-x11-fonts-base-7.0-1
xorg-x11-fonts-ISO8859-1-100dpi-7.0-1
xorg-x11-fonts-ISO8859-1-75dpi-7.0-1
xorg-x11-fonts-misc-7.0-1
xorg-x11-fonts-Type1-7.0-1
xorg-x11-font-utils-1.0.1-1
xorg-x11-proto-devel-7.0-1
xorg-x11-resutils-1.0.1-1
xorg-x11-server-utils-1.0.1-1
xorg-x11-server-Xnest-1.0.1-1
xorg-x11-server-Xorg-1.0.1-1
xorg-x11-twm-1.0.1-1
xorg-x11-utils-1.0.1-1
xorg-x11-xauth-1.0.1-1
xorg-x11-xdm-1.0.1-1
xorg-x11-xfs-1.0.1-1
xorg-x11-xfwp-1.0.1-1
xorg-x11-xinit-1.0.1-1
xorg-x11-xkbdata-1.0.1-1
xorg-x11-xkb-utils-1.0.1-1
xorg-x11-xsm-1.0.1-1
[root P4C800ED ~]# rpm -q rhplx package rhplx is not installed
[root P4C800ED ~]# yum install rhplx
Setting up Install Process
Setting up repositories
extras-dev: ################################################## 3/3
Reading repository metadata in from local files
Parsing package install arguments
No Match for argument: rhplx
Nothing to do
[root P4C800ED ~]#

--
Regards,

Old Fart
(my reply-to address is "munged" to defeat spambots)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]