[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rawhide report: 20060207 changes



On Tue, 2006-02-07 at 10:46 -0500, Jeremy Katz wrote:
> On Tue, 2006-02-07 at 11:43 +0100, Ralf Corsepius wrote:
> > On Tue, 2006-02-07 at 03:34 -0500, Build System wrote:
> > > New package gnome-python2-desktop
> > > autoconf-2.59-6
> > > ---------------
> > > * Mon Feb 06 2006 Karsten Hopp <karsten redhat de> 2.59-6
> > > - check for Xlib.h instead of Intrinsic.h to find X11 headers
> > >   (#176379)
> > 
> > Not necessarily a good idea, because this renders FC generated configure
> > scripts unnecessarily incompatible to FSF autoconf generated ones.
> 
> The patch is also applied to upstream autoconf.  See
> http://lists.gnu.org/archive/html/bug-autoconf/2005-09/msg00024.html
Upstream == autoconf-2.60
== untested, unreleased, potentially buggy.

However, what upstream does, doesn't matter in this case:
You have hacked a autoconf-2.59 in a proprietary way, FC5-autoconf
generated scripts will be non-reproducible on other platforms.

As an isolated FC5 specific hack, this step is not helpful - If upstream
introduces it to autoconf-2.60, this change would be helpful.

Also, this patch is meaningless/non-functional when using vanilla
autoconf-2.59 generated configure scripts on FC5, nor does it fix
configure scripts having been generated by ancient autoconf version.

Ralf



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]