[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Request for volunteers: xfs config corrupted during upgrade - bug 179006



A couple people have reported a bug in which xfs fails to start
properly due to the config file being corrupted upon install.

Something is causing one of the config file lines later in the
file (default-point-size) to be inserted into the list of font
directories, which of course breaks xfs startup.

My assumption is that chkfontpath is causing this, however if
that turns out to be true, it will be quite odd for this to just
start happening all of a sudden, as chkfontpath hasn't really
changed substantially in a long time.

Another possibility is that rpm post script processing in some
package (or packages) are modifying the xfs config and causing
this to happen, or causing it to be in a state that chkfontpath
never would have encountered before.

Unfortunately, there is no 100% reproduceable test case yet in
order to easily debug the problem, so I would like everyone who
experiences this problem to CC themselves on the master bug that
is tracking this issue, and add any information that might help
to narrow the problem down, as this bug is potentially one of
the nastiest X bugs on the FC5Blocker list, since a non-starting
font server means a non starting X server.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=179006

I'm going to continue trying to trigger the issue locally, but
any assistance in narrowing down a reproduceable test case and/or
diagnosing the issue is appreciated.  You can also find me on
#fedora-x on freenode.

TIA

--
Mike A. Harris  *  Open Source Advocate  *  http://mharris.ca
                      Proud Canadian.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]