[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC5T3 on x86_64



Jeremy Katz wrote:

On Tue, 2006-02-21 at 16:47 +1100, Bojan Smojver wrote:
I'm trying to upgrade an FC4 box (x86_64) to FC5T3, but I'm getting an error just after "Preparing transaction from the installation media". Basically, the message is something like "We should really show you the debug info here, but we'll just fail instead." On VT3 I can see that there are file conflicts between packages from FC4 and FC5T3, namely for xpdf, xorg-x11-devel, python-devel, vim-common and e2fsprogs. Not sure if those are harmless or if they are actually causing the install to stop.

Yes, the conflicts will currently cause things to stop.  Could you file
the list so that we can add them to the handler for these.

Jeremy

this behavier is *wrong*
failing because a conflict on update without even tell the user about them isn't the right thing to do.
what if sb has third party packages that conflicts with the new ones?
the user should be asked if he/she wants to remove this package and proceed (can install them after the upgrade is done) or abort the install to solve the problem.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]