[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Multiple concurrent versions of Python



On Wed, 2006-02-22 at 18:16 +0100, Aurelien Bompard wrote:
> Jeremy Katz wrote:
> > I really think that this needs to be resolved by making those apps work
> > better with more current versions of python.  By that argument, what if
> > someone wanted to build an app which was only "supported" on a 2.4
> > kernel -- would you argue that we should also add the infrastructure for
> > supporting a variety of incompatible kernel versions?
> 
> Agreed, the right way is to make Zope work with python 2.4.
> But now, how to make that a reality ? Zope says :
> "Python 2.4.X will be supported when a security audit took place"
> I maintain the Zope rpm, but I sure can't do such a security audit.
> Does that mean Zope will remain unsupported in Fedora ? What alternative do
> we have ?
> 
What about helping to port Plone to Zope 2.9.x?  Is the Plone project
working on this/open to this kind of contribution?  Does Plone currently
run on zope-2.9/python-2.4 but just is not "supported"?

Some background for those that want it:

Zope maintains several branches.  Currently they are pushing 2.9.x and
3.2.x (which is incompatible with Zope 2).  python-2.4 is the supported
platform for both of these.  Plone is a major add-on for Zope 2 which
makes CMS work much easier.  Plone lists Zope-2.8 (which the Zope devs
say is most definitely not supported on python-2.4) as its supported
platform.  Zope 3 has features which are supposed to largely replace the
need for Plone but that doesn't help people who have already deployed a
Zope+Plone solution.

-Toshio

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]