[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Multiple concurrent versions of Python



Guyz,

Zope 2.8.5 and greater support Python 2.4 officially.  Zope-2.9.x and
Zope 3 actually *require* it.

Plone's dependency chain is a little more complex.  Adventurous people
are running it on Zope-2.9, although I'd not recommend it.  The 2.5
series of Plone will run on CMF-2.x which will definitely run on
Zope-2.9, I'm not sure if there are issues with a 2.8.x port of this.

We have an extensive set of Zope and Plone RPM's at
https://linux.last-bastion.net/RPC2/up2date/plope, but we've not
received much interest from any of the major Zope/Plone ISV's.

There is presently a community push into egg territory, which is rather
an anathema for RPM packagers.

I'd absolutely not recommend attempting to package a lot of this stuff
unless you actually intend to hang out on zope-dev and/or plone-dev as
these are rather nuanced fast-moving targets.

Alan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]