[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Multiple concurrent versions of Python



On Thu, 2006-02-23 at 19:48 +1100, Alan Milligan wrote:
> Toshio Kuratomi wrote:
> 
> > So from the outside looking in, zope-2.9.x is where python-2.4
> > compatibility starts.
> > 
> I've been making contributions to the Zope project for about four years
> now, and follow it very closely.  If you'd cared to look in the Zope dev
> archives, you'd have seen posts from me regarding exactly this issue for
> perhaps 8 months now.
> 
If Zope-dev was searchable, I'd have found the information before
posting; Google on site:mail.zope.org only pulls out the Zope-announce
announcement that Zope-2.8.5 is still not supported with python-2.4.
(I've now found out that marc.theaimsgroup keeps archives of zope-dev as
well so I'll use that in the future.)  Your posting here said that
zope-2.8.5 _officially_ supported python-2.4 but all the official
announcements I found say unsupported.

Now that I know the posts are in zope-dev and from you, here's the
thread I found:
http://mail.zope.org/pipermail/zope-dev/2005-November/025908.html
http://mail.zope.org/pipermail/zope-dev/2005-December/025967.html

Which says that zope-2.8.4+ has been security audited for python 2.4 but
2.8.x is not official on python-2.4 and there is no plan to change this.

From Jim Fulton:
'''
What Andreas is saying is that Python 2.4 still isn't supported
for Zope 2.8.  This is different from a statement about a security
audit.  The security audit evaluated and addressed issues arising
from a change from Python 2.3 to python 2.4.  Zope 2.8.4 reflects
this.  We still choose not to support Python 2.4 for Zope 2.8 because
there hasn't been any sort of test release cycle for Zope 2.8 with
Python 2.4.  Zope 2.9 will go through such a cycle which will give us
at least some consequence.
'''

As long as Aurelian has satisfied Andreas Jung with the warnings that
support for the FC Zope 2.8.x on python-2.4 is not supported by the Zope
Project and that the current release of Plone is not ready for 2.9 then
I think we can continue shipping 2.8.x with our system python in the
short term.  But in the longer term this is a trap because upstream's
stance means we risk antagonizing them if we want to go to them for help
solving problems.

-Toshio

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]