[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: nfs-utils dependency error



Le Mar 27 juin 2006 13:46, Jesse Keating a écrit :
> On Tue, 2006-06-27 at 13:19 +0200, Nicolas Mailhot wrote:
>>
>> IMHO the good answer is we botched things, because even if a user got
>> old
>> repositories configured, things should just work.
>
> Yes and no.  If you're using rawhide, you _really_ shouldn't be using
> -updates from the previous release.  The collection of rawhide already
> inherits all packages from FC5-updates, but can have overriding
> packages.  The build root is different, the packages built have
> different options, so on and so forth.  -updates from the previous
> release are not meant for use within development and things can break.

True. However my personal take on this is updates from the previous
release should never have a NEVR higher than that of rawhide, because that
will screw moving from previous to rawhide which is a valid use-case.

So even if updates frome previous do not work with rawhide, they should
never be applied by the package manager even if the old repo is still
configured. If that is not the case this is a repo, not user problem

-- 
Nicolas Mailhot


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]