[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

problems with install : LVM2 corruption



Hi,
I managed to install FC6 but ran into a few problems in the process
(good ISO, verified CD). I had some LVM2 groups from FC4 and FC5 (and
possibly before) which I was going to have FC6 overwrite. I selected
custom partioning in the install and I tried to Edit the groups and
give them new mount points for FC6. There was some kind of error which
I didn't pay too much attention to at the time. If I recall correctly
it said something like there needed to be an extended partition for
LVM to work. Since I already had /hda2 marked as an LVM2 partition I
clicked around trying to convince Anaconda that all was well. I am
quite sure the only button I ever clicked was Edit on a partition (no
Add/Delete) because I was trying re-use existing volume groups. I then
carried on to the next step of preparing the partitions. Anaconda then
crashed. I tried reinstalling it but when the custom partioning screen
came up none of the LVM groups were visible. Since I still had a few
regular 4GB partitions around from some earlier FC installation I
installed FC6 there instead and left everything else alone because I
thought I could propably fix any LVM problems easier on a running
system.

Now I am running FC6 but I cannot mount any of my LVM volume groups. I
tried try to list the groups initially using something like vgscan.
The VolGroup00 showed up but it was missing one field which seemed odd
(2nd from the top I think, I didn't write it down).

If I try a vgscan now though nothing shows up.

Is there any way I can try to recover my LVM volume groups? Here's
some more details:

fdisk /dev/hda
p

  Device Boot      Start         End      Blocks   Id  System
/dev/hda1               1        3648    29302528+   5  Extended
/dev/hda2            3649       24792   169839180   8e  Linux LVM
/dev/hda5               1         608     4883697   83  Linux
/dev/hda6             609        1216     4883728+  83  Linux
/dev/hda7            1217        1824     4883728+  83  Linux
/dev/hda8            1825        2432     4883728+  83  Linux
/dev/hda9            2433        3040     4883728+  83  Linux
/dev/hda10  *        3041        3053      104391   83  Linux

I had at least the following:
/dev/mapper/VolGroup00-home
/dev/mapper/VolGroup00-music
/dev/mapper/LogVol00

Unfortunately, I was going to backup my home folder but then I
thought, I've never had any problems before with Fedora, why bother?
Oops.

Any help would be appreciated!
Thanks,
Patrick


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]