[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Yum] Cannot find a valid baseurl for repo: core



Peter Eriksen wrote:
Hi list,

Recently I started getting the following error on Rawhide, when trying
to update using yum:

[peter localhost ~]$ su -c 'yum update'
Password: Deprecated constant TYPE_INTERFACE during plugin initialization.
Please use TYPE_INTERACTIVE instead.
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
Could not retrieve mirrorlist
http://fedora.redhat.com/download/mirrors/fedora-core-5.91.1 error was
[Errno 14] HTTP Error 404: Date: Wed, 13 Sep 2006 09:13:15 GMT
Server: Apache
Last-Modified: Wed, 13 Sep 2006 08:45:35 GMT
ETag: "109cab-105b-4507c52f"
Accept-Ranges: bytes
Content-Length: 4187
Content-Type: text/html

Error: Cannot find a valid baseurl for repo: core
[peter localhost ~]$

My development section of the repository configuration is:

======== /etc/yum.repos.d/fedora-development.repo =====
[development]
name=Fedora Core - Development
baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/development/$basearch/os/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=rawhide&arch=$basearch
enabled=1
gpgcheck=0
=======================================================

I don't get any responses to "ping download.fedora.redhat.com", and my
internet connection works otherwise.

Did the download servers disappear, or is the problem on my end?  What
do I put in "baseurl" to make things work again?


Regards,

Peter

Look like you have enabled the core repo (/etc/yum.repos.d/fedora-core), it can't be used with a test release/rawhide because there is no core repo for release 5.91. The $releasever in the mirrorlist url is substituted with the current release.
Just set enabled=0 in the core repo, and you be running again.

Tim


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]