[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fedora Core 5 can not execute some commands in a right way



On 9/27/06, Svetoslav Chukov <hydra nhydra org> wrote:
Hello!
My name is Svetoslav Chukov.
First of all, sorry about that disturbing...

I use Fedora Core 5 and noticed some bugs while using it. Let me explain
what is the problem... i tried several times to start some .run files
but always had an error result.
So, I opened one of these files and sew strange actions of fedora. For
example i could not start the shell script below that has of the head
of .run file. The problem is that in Fedora Core 5 i get different
result for CRC check and MD5 sum, but everything was fine in OpenSUSE
and some other distros.
So, i would like to understand the reason of the actions of my FC5.
Here is one of the command that can not be executed in FC5:
  "sum1=`tail $1 | cksum | sed -e 's/ /Z/' -e 's/  /Z/' | cut -dZ"

This command was inside of .run file, but is not only this example. The
entire .run script is executed in wrong way, the all commands. I tried 2
or 3 .run scripts and have the same result on all.

Thanks for the reading.
Best Regards,
Svetoslav

Svetoslav,

You need to set _POSIX2_VERSION=199209 before you try to use older
.run installers.
E.g.:
$ su -
  <password>
$ export _POSIX2_VERSION=199209
$ sh ./some-random-game-installer.sh

Other then that, please post FC5-related messages in Fedora users list
(fedora-list redhat com) and not in the Fedora-development list
(fedora-devel-list redhat com).

Thanks,
- Gilboa


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]