[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC5 "rpmbuild -ta" problems



On Fri, 2006-09-29 at 17:48 -0400, David Malcolm wrote:
> On Fri, 2006-09-29 at 16:31 -0300, Marcio Oliveira wrote:
> > Dave,
> > 
> >    I tested your script in my FC5 and got the following results:
> > 
> > Package tested: rpm-build-4.4.2-15.2 (FC5 original package)
> > Result: If RH bug 206841 is present, expect to see a series of error
> > lines complaining about missing fields 
> > **** Start of rpmbuild log ****
> > error: Name field must be present in package: (main package)
> > error: Version field must be present in package: (main package)
> > error: Release field must be present in package: (main package) 
> > error: Summary field must be present in package: (main package)
> > error: Group field must be present in package: (main package)
> > error: License field must be present in package: (main package)
> > 
> > Package tested: rpm-build-4.4.2-15.2 (patched)
> > Result: success
> > Wrote: /tmp/tmp.dZYmu16297/rpmbuild/SRPMS/foobarbaz-1.0-1.src.rpm
> > Wrote: /tmp/tmp.dZYmu16297/rpmbuild/RPMS/noarch/foobarbaz-1.0-1.noarch.rpm
> > 
> >   After patch the rpm-build I build lots of rpm packages from tarball
> > packages, and all of them are working fine in my system. 
> 
> Thanks for testing the script: looks like this is a good minimal
> reproducer case for the bug.
> > 
> >   According to the tar command errors from FC5 original rpm-build
> > package, tar command expects to receive "--wildcards" as a parameter
> > (to accept the "*" character in "file to stract" field), and "xOvf"
> > parameters plus a "-" (-xOvf) to extract the file. That is what I
> > added to rpm-4.2.2/build.c file. 
> > 
> >    Do you think this problem is a rpmbuild "wrong parameters problem"
> > or a tar "expected parameters problem"?
> 
> A bit of both?  IIRC a lot changed in the latest "tar", and it got
> fussier; does it support --wildcards in an earlier incarnation?  If so,
> I'm inclined to suggest that rpm-build should supply the arg so it can
> work with old and new tar.
> 
> I hope that regardless, FC6 would ship with an rpm-build/tar pair that
> work together - though I'm not the maintainer of either package, just
> another person who ran into the bug (hence the test)
> 
> BTW, this is one of the tests I've written for testing Fedora in Will
> Wood's "beaker" lab.  We've set things up so that tests can be packaged
> as RPMs, and I've got a yum repo here:
> http://people.redhat.com/dmalcolm/rhts-test-repo/
> 
> (the RPM containing the test is the rather verbosely-named
> rhts-testing108-sandbox-rpm-rpm-build-rpmbuild-of-tarball-smoketest-tests-1.1-102.noarch.rpm
> - the build process takes the path of the test within our result
> namespace)
> 
> I'm gonna go and try the tests on a variety of boxes...
Fails on rawhide-20060929/i386:   http://tinyurl.com/n86xa
Fails on rawhide-20060929/x86_64: http://tinyurl.com/po83j

Passes on FC5-GOLD/i386:          http://tinyurl.com/qd48s
Passes on FC5-GOLD/x86_64:        http://tinyurl.com/rcvgp

Hope this helps
Dave

[snip]


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]