[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: hal + pam update errors



i have a default fc7 t3 installation (x64) and than i just updated and those errors are popping up.
and i indeed have 2 hal and pam packages installed.. i386 and x86_64 (don`t know why linux wants to install both architectures)

i now did (the forced way i was talking about earlyer):
rpm -e hal.i386 --nodeps
rpm -e pam.i386 --nodeps
yum -y update

than worked perfectly.
and this wasn`t a bug that i could not solve :) it`s more meant as a "bug report" but i don`t find this worth posting on bugzilla so i made a notice of it here.

2007/4/5, KH KH <kwizart gmail com>:
2007/4/5, Mark <markg85 gmail com>:
> Hey,
>
> yesterday my pc spend a few hours downloading about 230 updates (from Test
> 3) and it ended up with ERRORS!!!!!
>
> Error Summary
> -------------
>
> [root localhost ~]# yum -y update
>
>
> Transaction Check Error:
>   file /usr/share/man/man5/namespace.conf.5.gz from install
> of pam-0.99.7.1-4.fc7 conflicts with file from package pam-0.99.7.1-3.fc7
>   file /usr/share/man/man8/pam_namespace.8.gz from install
> of pam-0.99.7.1-4.fc7 conflicts with file from package pam-0.99.7.1-3.fc7
>   file /usr/share/man/man8/pam_selinux.8.gz from install of
> pam-0.99.7.1-4.fc7 conflicts with file from package pam-0.99.7.1-3.fc7
>   file /usr/share/hal/fdi/fdi.dtd from install of hal-0.5.9-1.fc7 conflicts
> with file from package hal-0.5.9-0.git20070304.fc7
>   file
> /usr/share/hal/fdi/information/10freedesktop/10-usb-music-players.fdi
> from install of hal-0.5.9-1.fc7 conflicts with file from package
> hal-0.5.9-0.git20070304.fc7
>   file
> /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-acer.fdi
> from install of hal-0.5.9-1.fc7 conflicts with file from package
> hal-0.5.9-0.git20070304.fc7
>   file /usr/share/hal/fdi/information/10freedesktop/20-
> video-quirk-pm-apple.fdi from install of hal-0.5.9-1.fc7 conflicts with file
> from package hal-0.5.9-0.git20070304.fc7
>   file
> /usr/share/hal/fdi/information/10freedesktop/20- video-quirk-pm-asus.fdi
> from install of hal-0.5.9-1.fc7 conflicts with file from package
> hal-0.5.9-0.git20070304.fc7
>   file
> /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-dell.fdi
> from install of hal-0.5.9-1.fc7 conflicts with file from package
> hal-0.5.9-0.git20070304.fc7
>   file
> /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-fujitsu.fdi
> from install of hal-0.5.9-1.fc7 conflicts with file from package
> hal-0.5.9-0.git20070304.fc7
>   file /usr/share/hal/fdi/information/10freedesktop/20-
> video-quirk-pm-hp.fdi from install of hal-0.5.9-1.fc7 conflicts with file
> from package hal-0.5.9-0.git20070304.fc7
>   file
> /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-ibm.fdi
> from install of hal-0.5.9-1.fc7 conflicts with file from package
> hal-0.5.9-0.git20070304.fc7
>   file
> /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-misc.fdi
> from install of hal-0.5.9-1.fc7 conflicts with file from package
> hal-0.5.9-0.git20070304.fc7
>   file
> /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-sony.fdi
> from install of hal-0.5.9-1.fc7 conflicts with file from package
> hal-0.5.9-0.git20070304.fc7
>   file /usr/share/hal/fdi/information/10freedesktop/20-
> video-quirk-pm-toshiba.fdi from install of hal-0.5.9-1.fc7 conflicts with
> file from package hal-0.5.9-0.git20070304.fc7
>   file
> /usr/share/hal/fdi/policy/10osvendor/10-keyboard-policy.fdi
> from install of hal-0.5.9-1.fc7 conflicts with file from package
> hal-0.5.9-0.git20070304.fc7
>   file
> /usr/share/hal/fdi/policy/10osvendor/10-power-mgmt-policy.fdi
> from install of hal-0.5.9-1.fc7 conflicts with file from package
> hal-0.5.9-0.git20070304.fc7
>   file
> /usr/share/hal/fdi/policy/10osvendor/10-toshiba-buttons.fdi
> from install of hal-0.5.9-1.fc7 conflicts with file from package
> hal-0.5.9-0.git20070304.fc7
>   file
> /usr/share/hal/fdi/policy/10osvendor/20-acl-management.fdi
> from install of hal-0.5.9-1.fc7 conflicts with file from package
> hal-0.5.9-0.git20070304.fc7
>   file
> /usr/share/hal/fdi/policy/10osvendor/20-storage-methods.fdi
> from install of hal-0.5.9-1.fc7 conflicts with file from package
> hal-0.5.9-0.git20070304.fc7
>
> Error Summary
> -------------
>
> that`s it for the errors.
> i can probably bypass the errors by simply remove the existing packages with
> force :P
>
> --
> fedora-devel-list mailing list
> fedora-devel-list redhat com
> https://www.redhat.com/mailman/listinfo/fedora-devel-list
>

Hi!
Do you use multilib?
I had the same error and i was fixed doing:
rpm -e hal.i386
I'm using x86_64 but only x86_64 version were updated on x86_64!

Nicolas (kwizart)

--
fedora-devel-list mailing list
fedora-devel-list redhat com
https://www.redhat.com/mailman/listinfo/fedora-devel-list


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]