[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: hal + pam update errors



On Thu, 5 Apr 2007 14:20:01 -0400, Jesse Keating wrote:

> On Thursday 05 April 2007 14:13:18 Michael Schwendt wrote:
> > Making hal-libs obsolete hal will work, as hal-libs.i386 will then
> > replace the old hal.i386 also for x86_64.
> 
> We already tried that.  It doesn't work as the user doesn't have hal-libs.i386 
> installed yet.  Instead the user sees no update for their hal.i386.

Really? Then "Obsoletes" in Fedora 7 is broken.

The old hal.i386 on x86_64 is installed (else it would not conflict), but
not available in the x86_64 repo anymore. When hal-libs.i386 (in the
x86_64 repo) obsoletes hal, this means that hal-libs.i386 will replace
hal.i386. Yum will pull in hal-libs.i386 and remove hal.i386 -- if it
doesn't, behaviour has changed.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]