[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: yum-presto 0.3.4



On Thu, 2007-04-05 at 14:53 +0200, Tim Lauridsen wrote:
> This error is Python 2.5 related, cElementTree is included in Python 2.5.
> 
> Something like this will make it work in both python 2.4 (FC6) and 
> Python 2.5 (FC7)
> 
> try:
>     from cElementTree import interparse # Python 2.4
> except:
>     from xml.etree.cElementTree  import interparse # Python 2.5
> 
> Tim
> 
If somebody using Rawhide would like to test this and tell me if this at
least keeps presto from crashing yum.

The file you need to edit is /usr/share/presto/prestomdparser.py, and
the line you need to replace is "from cElementTree import interparse".

Jonathan

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]