[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

hal: multilib prob on x86-64 repo



with the x86_64 repo, the yum update fails with hal:

Transaction Check Error:
file /usr/share/man/man1/hal-disable-polling.1.gz from install of hal-0.5.9-1.fc7 conflicts with file from package hal-0.5.9-0.git20070401.1.fc7 file /usr/share/man/man1/hal-find-by-capability.1.gz from install of hal-0.5.9-1.fc7 conflicts with file from package hal-0.5.9-0.git20070401.1.fc7
...................

because both i386 and x86_64 are installed, but only hal.x86_64 is included in the x86_64 repo.

But hal.i386 is needed for gnome-vfs2:

rpm -e hal.i386
error: Failed dependencies:
libhal-storage.so.1 is needed by (installed) gnome-vfs2-2.18.0.1-1.fc7.i386 libhal.so.1 is needed by (installed) gnome-vfs2-2.18.0.1-1.fc7.i386

which in turn is needed by firefox.i386 which is required to use flash.

Both firefox.i386 and gnome-vfs2 are in the x86_64 repo.

I got hal.i386 and hal-libs from the i386 repo, and that worked.

Is there some to guard against not having i386 deps in the x86_64 repo. Or do we just have to remember that hal is a dep of firefox.i386?

sean


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]