[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: yum wont upgrade noarch -> arch-specific



On Sun, Apr 08, 2007 at 03:28:29PM -0400, Matthew Miller wrote:
> On Sun, Apr 08, 2007 at 02:26:08PM -0500, Michael E Brown wrote:
> > Should have posted this, because I ran it several times while verifying things:
> > $ sudo yum list firmware-addon-dell
> [...]
> > Installed Packages
> > firmware-addon-dell.noarch               1.2.6-1.fc6            installed       
> > Available Packages
> > firmware-addon-dell.x86_64               1.2.10-1.fc6           extras 
> 
> Forgive me if you posted this earlier and I missed it or if this is an
> insulting question, but: do you have exactarch=1 in your yum.conf?

Not insulting *at all*. At this point I would welcome a simple
explanation like that.

As it happens, it is a completely unchanged, stock yum.conf, which has
exactarch=1

Changing this to '0' does not fix the problem, though.

$ cat /etc/yum.conf     # note exactarch changed to 0
[main]
cachedir=/var/cache/yum
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=redhat-release
tolerant=1
obsoletes=1
gpgcheck=1
plugins=1
metadata_expire=1800
exactarch=0

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d


$ sudo yum --noplugins --disablerepo=livna* --disablerepo=freshrpms list
updates
Setting up repositories
Reading repository metadata in from local files

--
Michael


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]