[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: perl package split - if you maintain a perl-* module, read this message.



Jesse Keating <jkeating redhat com> writes:

> On Tuesday 17 April 2007 12:00:52 Robin Norwood wrote:
>> Well, the buildroots currently have 'perl-devel' because we made 'perl'
>> Require 'perl-devel' - which is obviously wrong for the long term, but
>> in the short term fixed the builds.  What we're doing now is further
>> splitting things out so there will be more packages, *and* removing the
>> Requires.  There's been some further discussion on
>> fedora-perl-devel-list about this, and the alternative is to *not* add
>> the new packages to the buildroots, and just have people fix their
>> packages.  Not to be a total weathervane here, but personally I'd just
>> as soon not add the packages to the buildroots, and fix the broken
>> packages now.  I just don't feel like I have enough of a feel for which
>> option people will prefer to make a call.  So, if you have an opinion,
>> speak up now.
>
> Personally I think it's rather late in the game to be doing such things, 
> especially because we only have one test release to get things right and the 
> final to correct what we got wrong.  I'd rather see the rest of this split 
> happen after F-7 is branched off devel/ and focus on getting it right in 
> devel/

I'd rather not go out with the current situation of perl Require-ing
perl-devel - just too much of a hack.  I admit I should've gotten this
straightened out earlier, but since it's a packaging change, likely to
affect a small group of package builders, I think the impact will be low
enough to bear the risk of going ahead with this.

-RN

-- 
Robin Norwood
Red Hat, Inc.

"The Sage does nothing, yet nothing remains undone."
-Lao Tzu, Te Tao Ching


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]