[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: perl package split - if you maintain a perl-* module, read this message.



>>>>> "MD" == Matt Domsch <Matt_Domsch dell com> writes:

MD> How many packages will break?

Pretty much everything starting with "perl-".

MD> How quickly can they be fixed?

The trivial fix (BuildRequires: perl-devel) is, well, trivial.  The
proper fix is to actually require the modules that the package needs
to build, which is usually perl(ExtUtils::MakeMaker) is easy but not
completely trivial.

Still, there are a lot of modules which will need even a trivial fix.

 - J<


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]