[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: perl package split - if you maintain a perl-* module, read this message.



On Wed, 2007-04-18 at 18:11 +0300, Ville Skyttä wrote:
> On Wednesday 18 April 2007, Jason L Tibbitts III wrote:
> >
> > The trivial fix (BuildRequires: perl-devel) is, well, trivial.  The
> > proper fix is to actually require the modules that the package needs
> > to build,
> 
> Right.
> 
> > which is usually perl(ExtUtils::MakeMaker) is easy but not 
> > completely trivial.
> 
> Looking at 5.8.8-16 in CVS, neither perl-devel nor perl(ExtUtils::MakeMaker) 
> is sufficient for the majority of cases.  perl-ExtUtils-MakeMaker should most 
> likely pull in perl(Test::Harness) (see the perl review bug in Bugzilla), but 
> in addition to that a lot of packages would need to have an explicit 
> perl(Test::More) build dependency added, that's commonly used in ./test.pl 
> and/or t/*.t in CPAN distributions.
> 
> There are also some Epoch issues in 5.8.8-16 which makes some of its 
> subpackages uninstallable, hopefully a fix will arrive soon.

Absolutely we urgently need a *-17 with the bugs fixes.

This *-16 can't and won't fly (IMNSHO this is a RELEASE BLOCKER)

Ralf




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]