[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problems upgrading to util-linux-ng in today's rawhide



On Fri, Aug 24, 2007 at 10:07:27AM -0600, Orion Poplawski wrote:
> /data/sw1/fedora/development/i386/os/Fedora/util-linux-ng-2.13-0.57.fc8.i386.rpm
> mount <= 2.11
> losetup <= 2.11
> schedutils <= 1.5
> util-linux <= 2.13.0.51
> setarch <= 2.0-4
> 
> # rpm -q setarch
> setarch-2.0-4.fc7
> 
> 
> Fails because setarch-2.0-4.fc7 > setarch-2.0-4 ?  Should it just be 
> "Obsoletes: setarch <= 2.0"?   Looks like it's fixed with "Obsoletes: 
> setarch <= 2.0-99", but I'm curious if the former would work.  Seems 
> best to avoid the release tag if possible.

Well, either it obsoletes all setarch versions, then it should
Obsoletes: setarch
or it is expected that setarch-2.0-5 might exist and might be compatible
with it, then it should be
setarch < 2.0-5
to deal with the %{dist} stuff.

	Jakub


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]