[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Broken BuildRequires in rawhide



On Mon, 2007-12-03 at 16:57 +0100, Michael Schwendt wrote:
> package: perl-Perl-MinimumVersion - 0.15-1.fc9.src from
> fedora-development-source
>   unresolved deps: 
>      perl(version) >= 0:0.7203

This is broken because perl(version) likes to play stupid games with its
versioning, and we have to use epoch to keep ordering sane. It is
currently at 2:0.74, but the perl(FOO) provides don't reflect epoch...
so:

[spot localhost ~]$ rpm -q perl-version --provides
perl(version) = 0.74
perl(version::vxs) = 0.74
vxs.so()(64bit)  
perl-version = 2:0.74-1.fc9

That should help the Perl::MinimumVersion maintainer fix the BR.

~spot


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]