[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: BuildRootOverrides request: devhelp (for vala-0.1.5)



On 04/12/2007, Jesse Keating <jkeating redhat com> wrote:
> On Tue, 4 Dec 2007 01:16:12 -0500
> "Michel Salim" <michel sylvan gmail com> wrote:
>
> > Could a CVS admin make devhelp available as a BuildRootOverrides?
> >
> > https://admin.fedoraproject.org/updates/F8/FEDORA-2007-3962
> >
> > Vala has a soft BR on devhelp -- the documentation files don't get
> > installed if devhelp is not detected at configure time, and everytime
> > there is a Firefox update, devhelp lags behind by days, so it will be
> > nice to have it permanently whitelisted.
>
>
> There isn't a method to make a "permanent" whitelist.  Why does your
> app have to be built against a very specific version of devhelp?
>
It does not have to. The problem is that the (rather frequent) Firefox
security fixes, and that devhelp is not whitelisted, means that at any
moment in time, it is quite probable that the newer version of Firefox
is already available in Koji, but the matching version of devhelp is
not.

The question should be the other way around -- why is devhelp
dependent on a specific version of Firefox, such that a security
bugfix breaks it. Hopefully xulrunner will solve it.


Any package that depends on devhelp would not be buildable from time
to time, because Koji would refuse to install devhelp, period.
Solution would be to either

1. Keep the previous version of Firefox available purely for
satisfying transitive dependencies like vala -> devhelp -> firefox
2. Always BRO devhelp as soon as Firefox is rebuilt

Thanks,

-- 
Michel Salim
http://hircus.jaiku.com/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]