[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: qscintilla2, eric4?



2007/12/15, Neal Becker <ndbecker2 gmail com>:
> I'm interested in eric4.  It needs qscintilla >= 2.1, while F8 has 1.7.1.
> Anyone looking into this?

My guess is that qscintilla isn't really a high priority for fedora
right now (how can i see who the package maintainers are for a certain
package??) so you might want to try to grab the .src.rpm of the last
rpm [1] made by fedora and upgrade it yourself.

to do this:
rpm -ivh packagename.src.rpm
go to /usr/src/redhat/SPECS/
run rpmbuild -ba the_specfile.spec (this is just to see that it
builds. if it's not building it will likely give you a list of
packages that you need in order to build it.) When the building works
than you can start adjusting the package to your demands. open up the
specfile (for example in nano, vi, gedit, kate etc) and look for the
source url (probably [2]). than you have to follow it, download the
latest version, put it the ../SOURCES dir (assuming your still in the
SPECS dir) and than adjust your specfile.
Now if your lucky than the build works and you have a new RPM which
you can install.. (don't count on it)

Good luck making it.

[1] = http://koji.fedoraproject.org/packages/qscintilla/1.7.1/3.fc8/src/qscintilla-1.7.1-3.fc8.src.rpm
[2] = http://www.riverbankcomputing.co.uk/qscintilla/download.php


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]