[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: gtksourceview-sharp packaging problem



On 12/17/2007 01:25 AM, Paul wrote:
Hi,

I've hit a snag when packaging a newer version of gtksourceview-sharp.

The package name is currently incorrect and it should really be
gtksourceview-sharp-2.0-0.10-25 (or as it is now 2.0-0.11-1). The
problem is that you can't have a - sign as part of the version.

Currently, the hack used is to define extra as 0.10 and then setup -q -n
to set up the directories. This is wrong, but I'm not sure how to get
the package name correct.

Is there a way to glob the bits together to create the correct name?

An "easy" fix might be to rename the package to gtksourceview-sharp2, like we do for gtk-sharp2 and gecko-sharp2 which have similar issues. It should be noted that the "2.0" is actually closer to part of the package name itself than part of the package version. It works with the 2.0 version of gtksourceview (or at least that's what it connotes to me, but looks like our gtksourceview-sharp package still builds against the 1.x version of it...hm...)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]