[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: gtkspell update



Michael Schwendt <mschwendt.tmp0701.nospam <at> arcor.de> writes:
> * Thu Dec 20 2007 Matthew Barnes <mbarnes <at> redhat.com> - 2.0.11-5.fc9
> - Add patch for RH bug #245888 (use Enchant).

This says what it says: gtkspell is now using enchant instead of aspell. For 
the rationale, see:
http://fedoraproject.org/wiki/Releases/FeatureDictionary

> compose.o: In function `compose_set_spell_lang_menu':
> /builddir/build/BUILD/sylpheed-2.4.8/src/compose.c:5331: undefined reference 
to `new_aspell_config'
> /builddir/build/BUILD/sylpheed-2.4.8/src/compose.c:5332: undefined reference 
to `get_aspell_dict_info_list'
> /builddir/build/BUILD/sylpheed-2.4.8/src/compose.c:5333: undefined reference 
to `delete_aspell_config'
> /builddir/build/BUILD/sylpheed-2.4.8/src/compose.c:5335: undefined reference 
to `aspell_dict_info_list_elements'
> /builddir/build/BUILD/sylpheed-2.4.8/src/compose.c:5336: undefined reference 
to `aspell_dict_info_enumeration_next'
> /builddir/build/BUILD/sylpheed-2.4.8/src/compose.c:5336: undefined reference 
to `aspell_dict_info_enumeration_next'
> /builddir/build/BUILD/sylpheed-2.4.8/src/compose.c:5342: undefined reference 
to `delete_aspell_dict_info_enumeration'

And this is Sylpheed trying to use aspell-related functions directly, so of 
course this doesn't work anymore. If Sylpheed really must use APIs of the 
underlying spellchecker instead of the gtkspell abstraction, it'll have to be 
patched to use enchant too. (Technically, those linker errors could probably be 
fixed by linking in aspell directly, but that'll not solve the actual problem 
because Sylpheed would then try to read the list of languages from aspell while 
gtkspell is actually using enchant.)

        Kevin Kofler


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]