[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Announcing repoman - PyGTK yum repo manager



On Sun, 2007-02-04 at 22:56 -0800, Peter Gordon wrote:
> On Mon, 2007-02-05 at 00:03 -0500, David Cantrell wrote:
> > python setup.py install
> > --root=/var/tmp/repoman-0.4-1.fc7-root-brewbuilder
> > running install
> > error: invalid Python installation: unable to open /usr/lib/python2.5/config/Makefile (No such file or directory)
> > 
> > It does work on rawhide though.
> 
> Hmm. According to repoquery, that file is part of the python-devel
> package in development/FC7, so you should add python-devel as a
> BuildRequires to your spec to fix this. 
> 
> Actually, I see a couple of other things that may need fixing in the
> spec file if you would be so kind for the next EVR bump. :]
> 
>       * Source0 should be a fully-qualified URI using macros if
>         appropriate (i.e.,
>         http://example.com/sources/%{name}-%{version}.tar.gz)
>       * You don't need to set %debug_package to %nil, since having the
>         package build as noarch makes rpmbuild automagically not do any
>         of the normal debuginfo stripping.
>       * Instead of hardcoding "%{_libdir}/python?.?/site-packages/" into
>         your %files section, you should instead define the %
>         python_sitelib macro and use that in your %files. (See the
>         Packaging/Python page on the wiki for more information.)
> 
> Does this BuildRequires fix it?

Yes, and all the above things have been fixed in repoman-0.5.  Packages
for FC-6 and rawhide are available:

http://www.boston.burdell.org/repoman/

Thanks,

-- 
David Cantrell <dcantrell redhat com>
Red Hat / Westford, MA

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]