[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problem running SWT apps on Sun JVM on Fedora 7?



2007/2/17, darrell pfeifer <darrellpf gmail com>:
On 2/17/07, Michel Salim <michel salim gmail com> wrote:
> 2007/2/16, Andrew Overholt <overholt redhat com>:
> > * Michel Salim <michel salim gmail com> [2007-02-12 17:09]:
> > > I *did* try running Fedora Eclipse against Sun Java (by mistake; the
> > > path to the JVM got added in front of /usr/bin when I reorganized my
> > > login scripts) and it did produce the same error.
> >
> > Can you file a bug about this?  I've done this myself and had no issues.
> > While we can't support running with the proprietary JVMs, i'm interested
> > to see what the issue is.
> >
> Certainly! The reason I posted here first, though, is ... which
> component do I file this against?
>

I'm using eclipse.org version of Eclipse 3.2 along with Sun JDK 1.6.0
on an updated rawhide. Eclipse has always worked perfectly until a
couple of days ago.

When I use the 32-bit JDK or JRE with the 32-bit Eclipse (SWT has to
be compiled against GTK on Unix platforms, thus SWT-using applications
are not arch-independent) everything works fine (apart from the
checkboxes). The problem I mentioned only affect Java/x86_64 and
64-bit SWT apps.

Currently checkboxes are broken. They don't seem to highlight
correctly when pressed and also seem to act as a button group even
though they're not. It makes even simple things (like using the file
import dialog to import files into a project) very difficult.

Yup. As Kevin mentioned, this affects PyGTK apps as well. Native GTK
apps (and Firefox) works fine for some strange reason.

--
Michel Salim
http://hircus.wordpress.com/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]