[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problem running SWT apps on Sun JVM on Fedora 7?



On Sat, 2007-02-17 at 21:47 -0500, Andrew Overholt wrote:
> Adding Ben Konrath to thread
> 
> * Michel Salim <michel salim gmail com> [2007-02-17 11:14]:
> > 2007/2/16, Andrew Overholt <overholt redhat com>:
> > >* Michel Salim <michel salim gmail com> [2007-02-12 17:09]:
> > >> I *did* try running Fedora Eclipse against Sun Java (by mistake; the
> > >> path to the JVM got added in front of /usr/bin when I reorganized my
> > >> login scripts) and it did produce the same error.
> > >
> > >Can you file a bug about this?  I've done this myself and had no issues.
> > >While we can't support running with the proprietary JVMs, i'm interested
> > >to see what the issue is.
> > >
> > Certainly! The reason I posted here first, though, is ... which
> > component do I file this against?
> 
> eclipse.  Bug components are created by SRPM and libswt3-gtk2 is a
> sub-package of the eclipse SRPM.
> 
> Please provide details of how your ran Eclipse and the output of:
> 
> which java
> which javac
> readlink -f `which java`
> readlink -f `which javac`
> rpm -qa --queryformat "%{name}-%{version}-%{release}.%{arch}\n" | egrep \
>   "eclipse|swt|^java-1|gcj"
> 
> It for sure doesn't work with eclipse -vm <path to jvm>/bin/java ?  And
> it *does* work with libgcj?
> 
> Ben:  can you think of anything I'm missing here?

The only thing I have to add is if the problem occurs with an upstream
download and a proprietary VM, then it's an upstream problem and you
should file a bug in the eclipse.org bugzilla. Please post the bug
number if you end up filing it so that we can track it and / or help out
if we can.

Thanks, Ben


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]