[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC6 updates broken deps?



seth vidal wrote:

and this is why the update system is writing out update data. So, we can
differentiate b/t update for feature and update for security, or
different grades of a security update.

then we can work more intelligently on:
yum update security-critical-only (as an example)


That would be a nice thing for sure, but would really depend on the inclusion of some sort of --continue-on-failure functionality of yum. It makes no sense to provide a "security updates only" option, if the 20 security updates in there could potentially be held back because of a dep problem with one of them.

I've said this a thousand times over and I'll say it again. I would *much* rather have 1 package with a known security problem (held back because of a dep issue with that package), than 20.

/Thomas


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]