[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: OpenSceneGraph



Ralf Corsepius wrote:
On Sun, 2007-07-01 at 09:47 -0600, Rick L Vinyard Jr wrote:
Ralf Corsepius wrote:
The devel libs conflict, so the only option I see is installing OSG-2's
devel libs into a %{_libdir}/osg-2.0 subdir.
Personally, I'd rather see the OSG-1 libs in an osg-1.0 subdir,
This would be incompatible to OSG-1 as it has been shipped until now.
True. But, so is upgrading to OSG-2 (which I think is fine).

and basically treat the OSG-1 packages as legacy packages. That way, the OpenSceneGraph package can just move ahead to 2.0 and packages that need OSG-1 will have to explicitly state it.
This is the replacing "OSG-1 by compat-OSG-1 packages" idea. It's only
applicable to the run-time packages, but not to the devel packages.
Why is it not applicable to devel packages? There are others that have:
   avahi-compat-howl-devel
   avahi-compat-libdns_sd-devel
   compat-guichan05-devel
   compat-guile-16-devel
   compat-libgda-devel
   compat-libosip2-devel
   compat-wxGTK-common-devel
   compat-wxGTK-devel
   compat-wxGTK2-devel
   compat-wxGTK26-devel



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]