[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

yum dependency resolution problem



I'm upgrading to Rawhide and I seem to be running into a problem with yum.

Calling "yum update libwnck" leads to the following output:

Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package libwnck.i386 0:2.19.5-3.fc8 set to be updated
--> Processing Dependency: libwnck-1.so.18 for package: gnome-system-monitor
--> Processing Dependency: libwnck-1.so.18 for package: gnome-applets
--> Processing Dependency: gtk2 >= 2.11.3 for package: libwnck
--> Processing Dependency: libwnck-1.so.18 for package: gnome-power-manager
--> Processing Dependency: libwnck-1.so.18 for package: gnome-panel
--> Processing Dependency: libwnck-1.so.18 for package: libwnck-devel
--> Processing Dependency: libwnck-1.so.18 for package: notification-daemon
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package libwnck.i386 0:2.19.5-3.fc8 set to be updated
---> Package gtk2.i386 0:2.11.6-3.fc8 set to be updated
--> Processing Dependency: libwnck-1.so.18 for package: gnome-system-monitor
--> Processing Dependency: libwnck-1.so.18 for package: gnome-applets
--> Processing Dependency: libwnck-1.so.18 for package: gnome-power-manager
--> Processing Dependency: libwnck-1.so.18 for package: gnome-panel
--> Processing Dependency: gtk2 = 2.10.11-7.fc7 for package: gtk2-devel
--> Processing Dependency: libwnck-1.so.18 for package: libwnck-devel
--> Processing Dependency: libwnck-1.so.18 for package: notification-daemon
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package gtk2-devel.i386 0:2.11.6-3.fc8 set to be updated
--> Processing Dependency: libwnck-1.so.18 for package: gnome-system-monitor
--> Processing Dependency: libwnck-1.so.18 for package: gnome-applets
--> Processing Dependency: libwnck-1.so.18 for package: gnome-power-manager
--> Processing Dependency: libwnck-1.so.18 for package: gnome-panel
--> Processing Dependency: libwnck-1.so.18 for package: libwnck-devel
--> Processing Dependency: libwnck-1.so.18 for package: notification-daemon
--> Finished Dependency Resolution
Error: Unresolveable requirement libwnck-1.so.18 for gnome-system-monitor
Error: Unresolveable requirement libwnck-1.so.18 for gnome-applets
Error: Unresolveable requirement libwnck-1.so.18 for gnome-power-manager
Error: Unresolveable requirement libwnck-1.so.18 for gnome-panel
Error: Unresolveable requirement libwnck-1.so.18 for libwnck-devel
Error: Unresolveable requirement libwnck-1.so.18 for notification-daemon

There are new versions of all these packages available however and when I force yum to pick them up using "yum update libwnck notification-daemon libwnck-devel gnome-panel gnome-power-manager gnome-applets gnome-system-monitor" then yum no longer complains.

Shouldn't yum pick these up automatically? (This is with
yum-3.2.2-3.fc8)

Regards,
  Dennis


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]