[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

kmod-em8300-PAE-debug - Re: Broken deps in Fedora 7 Test Updates



On Sat, 2 Jun 2007 18:48:58 +0300, Ville Skyttä wrote:

> On Saturday 02 June 2007, Michael Schwendt wrote:
> >
> > source rpm: em8300-kmod-0.16.2-6.2.6.21_1.3194.fc7.src.rpm
> > package: kmod-em8300-PAE-debug - 0.16.2-6.2.6.21_1.3194.fc7.i686 from
> > fedora-updates-testing-7-i386 unresolved deps:
> >      kernel-i686 = 0:2.6.21-1.3194.fc7PAE-debug
> 
> $ rpm -qp --provides kernel-PAE-debug-2.6.21-1.3194.fc7.i686.rpm
> [...]
> kernel-i686 = 2.6.21-1.3194.fc7PAE-debug
> 
> Perhaps something in what creates this report is broken, ie. not handling the 
> two dashes in the right-side "EVR" the same way as rpm, yum, and smart.  None 
> of those (tested on FC6) have any problem with this dependency.

Remember that yum 2.6.1 is the backend for repoclosure.

In this case, a whatProvides for "kernel-i686 EQ 0:2.6.21-1.3194.fc7PAE-debug"
doesn't find any provider.

When copying these two packages

  kmod-em8300-PAE-debug-0.16.2-6.2.6.21_1.3194.fc7.i686.rpm
  kernel-PAE-debug-2.6.21-1.3194.fc7.i686.rpm

into a local repository, the problem is not reproducible, and the
same yum query returns the kernel package.

I need to dig deeper.

The kmod-em8300-PAE-debug packages in FE6, have they ever before caused
false positives like here with F7?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]