[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: kmod-em8300-PAE-debug - Re: Broken deps in Fedora 7 Test Updates



On Sat, 2 Jun 2007 21:25:32 +0200, Michael Schwendt wrote:

> On Sat, 2 Jun 2007 18:48:58 +0300, Ville Skyttä wrote:
> 
> > On Saturday 02 June 2007, Michael Schwendt wrote:
> > >
> > > source rpm: em8300-kmod-0.16.2-6.2.6.21_1.3194.fc7.src.rpm
> > > package: kmod-em8300-PAE-debug - 0.16.2-6.2.6.21_1.3194.fc7.i686 from
> > > fedora-updates-testing-7-i386 unresolved deps:
> > >      kernel-i686 = 0:2.6.21-1.3194.fc7PAE-debug
> > 
> > $ rpm -qp --provides kernel-PAE-debug-2.6.21-1.3194.fc7.i686.rpm
> > [...]
> > kernel-i686 = 2.6.21-1.3194.fc7PAE-debug

$ sudo yum -c $(pwd)/yum.f7.conf --enablerepo=fedora-updates-testing-7-i386 --enablerepo=fedora-7-i386 list kernel-PAE-debug
Setting up repositories
Reading repository metadata in from local files
Available Packages
kernel-PAE-debug.i686                    2.6.21-1.3194.fc7      fedora-7-i386   

However:

$ sudo yum -c $(pwd)/yum.f7.conf --enablerepo=fedora-updates-testing-7-i386 --enablerepo=fedora-7-i386 localinstall kmod-em8300-PAE-debug-0.16.2-6.2.6.21_1.3194.fc7.i686.rpm 
Setting up Local Package Process
Examining kmod-em8300-PAE-debug-0.16.2-6.2.6.21_1.3194.fc7.i686.rpm: kmod-em8300-PAE-debug - 0.16.2-6.2.6.21_1.3194.fc7.i686
Marking kmod-em8300-PAE-debug-0.16.2-6.2.6.21_1.3194.fc7.i686.rpm to be installed
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package kmod-em8300-PAE-debug.i686 0:0.16.2-6.2.6.21_1.3194.fc7 set to be installed
--> Running transaction check
--> Processing Dependency: em8300-kmod-common >= 0.16.2 for package: kmod-em8300-PAE-debug
--> Processing Dependency: kernel-i686 = 2.6.21-1.3194.fc7PAE-debug for package: kmod-em8300-PAE-debug
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package em8300.i386 0:0.16.2-1.fc7 set to be updated
--> Running transaction check
--> Processing Dependency: kernel-i686 = 2.6.21-1.3194.fc7PAE-debug for package: kmod-em8300-PAE-debug
--> Finished Dependency Resolution
Error: Missing Dependency: kernel-i686 = 2.6.21-1.3194.fc7PAE-debug is needed by package kmod-em8300-PAE-debug


Yum bug? F6 metadata broken? These queries have been done with an up-to-date FC6.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]