[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Proposal: Automated rebuild script for the buildsys



Hello,

I had an idea today as I was running my usual update check. I'm not sure
if it's possible or feasible, but if it is possible to write I think it
would be a great feature for the buildsys.

Today I checked for updates and found:
firefox.i386                             2.0.0.4-1.fc7          updates
firefox-devel.i386                       2.0.0.4-1.fc7          updates
yelp.i386                                2.18.1-4.fc7           updates

If I try to update firefox or yelp, the dependency check fails because
firefox = 2.0.0.3 is needed by gnome-python2-gtkmozembed.

It's no trouble to wait a day or two for the gnome-python2-gtkmozembed,
but I was thinking what if there was a list on the buildsys that kept
track of certain packages like these - gnome-python2-gtkmozembed an yelp
would be listed against firefox for example as they both require
gecko-libs.

This way, when the version tag (not release tag) changed, yelp and
gnome-python2-gtkmozembed could be queued for rebuilding too so there
are fewer dependency errors.

Stewart


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]