[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: yum upgrade error http 404 on tsclient rpm



Gerry Reno wrote:
Gerry Reno wrote:
David Timms wrote:
Gerry Reno wrote:
Gerry Reno wrote:
I decided to try to yum upgrade an FC6 machine today to F7 so I installed the fedora-release rpms for F7 and then ran yum upgrade, but I'm getting 404 errors on package tsclient. It tries a bunch of mirrors and then says no more mirrors to try. Is anyone else seeing this?


Ok, I waited a while a retried this again. It goes along for quite a while and then finally gets these errors:

--> Finished Dependency Resolution
Error: Missing Dependency: libnetsnmp.so.10 is needed by package net-snmp-utils Error: Missing Dependency: mysql = 5.0.27-1.fc6 is needed by package mysql-bench Error: Missing Dependency: krb5-libs = 1.5-21 is needed by package krb5-server Error: Missing Dependency: mono-core = 1.1.17.1-4.fc6 is needed by package mono-data
Error: Missing Dependency: libdvdread.so.3 is needed by package k3b
Error: Missing Dependency: php-common = 5.1.6-3.6.fc6 is needed by package php-mbstring Error: Missing Dependency: libsndfile.so.1(libsndfile.so.1.0) is needed by package k3b Error: Missing Dependency: gnutls = 1.4.1-2 is needed by package gnutls-utils Error: Missing Dependency: python(abi) = 2.4 is needed by package aqbanking Error: Missing Dependency: qt = 1:3.3.7-0.1.fc6 is needed by package qt-ODBC Error: Missing Dependency: libgcj.so.7rh is needed by package libglade-java Error: Missing Dependency: poppler = 0.5.4-5.fc6 is needed by package poppler-utils Error: Missing Dependency: vim-common = 2:7.0.235-1.fc6 is needed by package vim-X11 Error: Missing Dependency: gcc = 4.1.1-51.fc6 is needed by package gcc-gnat Error: Missing Dependency: libgcj.so.7rh is needed by package libgconf-java Error: Missing Dependency: mono-core = 1.1.17.1-4.fc6 is needed by package mono-web Error: Missing Dependency: libpq.so.4 is needed by package postgresql-odbc Error: Missing Dependency: libsamplerate.so.0(libsamplerate.so.0.0) is needed by package k3b Error: Missing Dependency: libgcj.so.7rh is needed by package libgtk-java Error: Missing Dependency: mono-core = 1.1.17.1-4.fc6 is needed by package mono-data-sqlite Error: Missing Dependency: nmap = 2:4.11 is needed by package nmap-frontend Error: Missing Dependency: unixODBC = 2.2.11-7.1 is needed by package unixODBC-kde Error: Missing Dependency: libpisock.so.8 is needed by package gnome-pilot-conduits Error: Missing Dependency: libavahi-core.so.4 is needed by package avahi-tools Error: Missing Dependency: libgcj.so.7rh is needed by package cairo-java Error: Missing Dependency: openldap = 2.3.30-2.fc6 is needed by package openldap-servers Error: Missing Dependency: gcc = 4.1.1-51.fc6 is needed by package gcc-objc
Error: Missing Dependency: libsndfile.so.1 is needed by package k3b
Error: Missing Dependency: net-snmp = 1:5.3.1 is needed by package net-snmp-utils Error: Missing Dependency: python(abi) = 2.4 is needed by package avahi-tools Error: Missing Dependency: avahi = 0.6.16 is needed by package avahi-tools Error: Missing Dependency: mysql = 5.0.27-1.fc6 is needed by package mysql-devel Error: Missing Dependency: qt = 1:3.3.7-0.1.fc6 is needed by package qt-MySQL Error: Missing Dependency: libnetsnmp.so.10 is needed by package stonith Error: Missing Dependency: libedataserver-1.2.so.7 is needed by package evolution-sharp Error: Missing Dependency: libgcj.so.7rh is needed by package libgnome-java
Error: Missing Dependency: libsamplerate.so.0 is needed by package k3b
Error: Missing Dependency: neon = 0.25.5-5.1 is needed by package neon-devel Error: Missing Dependency: hal = 0.5.8.1-6.fc6 is needed by package hal-gnome Error: Missing Dependency: libgcj.so.7rh is needed by package libvte-java
I think this is because some of the packages {tsclient} are not in "what was previously known as core": http://ftp.iinet.net.au/pub/fedora/linux/releases/7/Fedora/i386/os/Fedora/

If you do the upgrade using the Everything, you might have better luck since it includes what was known as extras {needed for some of the packages you currently have installed}:
http://ftp.iinet.net.au/pub/fedora/linux/releases/7/Everything/i386

The other option is to rpm -qa>mypackages.txt, then remove the packages that cause problems, and then upgrade.

DaveT.

Hmm... I don't think I want to do an Everything upgrade on this server. As far as removing packages. Sure as heck if I start removing some of these it will break some other dependencies. I just don't see why it says all these are missing as they are all installed:

rpm -q mysql krb5-libs mono-core php-common gnutls python qt poppler vim-common gcc nmap unixODBC openldap net-snmp avahi mysql neon hal

mysql-5.0.27-1.fc6
krb5-libs-1.5-21
mono-core-1.1.17.1-4.fc6
php-common-5.1.6-3.6.fc6
gnutls-1.4.1-2
python-2.4.4-1.fc6
qt-3.3.7-0.1.fc6
poppler-0.5.4-5.fc6
vim-common-7.0.235-1.fc6
gcc-4.1.1-51.fc6
nmap-4.11-1.1
unixODBC-2.2.11-7.1
openldap-2.3.30-2.fc6
net-snmp-5.3.1-14.fc6
avahi-0.6.16-4.fc6
mysql-5.0.27-1.fc6
neon-0.25.5-5.1
hal-0.5.8.1-6.fc6


Reran the upgrade again and same result. Ok, now I need the 'yum undo'. How can I reset everything back with yum. So it quits saying 'set to be installed' to a big list of packages.


I went and looked at the list of packages and dependencies again and it looks like some of the missing dependencies are for packages that have been marked for update to newer versions. So why isn't yum requiring newer versions of the packages for which it is complaining the dependencies are missing? Yum depsolv seems to be messed up. Using yum 3.0.6.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]