[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: yum upgrade error http 404 on tsclient rpm



On Sun, 24 Jun 2007 18:16:23 -0400, Gerry Reno wrote:

> Gerry Reno wrote:
> > I decided to try to yum upgrade an FC6 machine today to F7 so I 
> > installed the fedora-release rpms for F7 and then ran yum upgrade, but 
> > I'm getting 404 errors on package tsclient.  It tries a bunch of 
> > mirrors and then says no more mirrors to try.  Is anyone else seeing 
> > this?
> >
> >
> Ok, I waited a while a retried this again.  It goes along for quite a 
> while and then finally gets these errors:
> 
> --> Finished Dependency Resolution
> Error: Missing Dependency: libnetsnmp.so.10 is needed by package 
> net-snmp-utils
> Error: Missing Dependency: mysql = 5.0.27-1.fc6 is needed by package 
> mysql-bench

You need to enable the Fedora "Everything" repository to upgrade several
of your packages from Fedora 6.

The rest of your messages are based on misinterpreting the Yum error
messages. For example:

| Error: Missing Dependency: mysql = 5.0.27-1.fc6 is needed by package 
| mysql-bench

This can mean two things, but in your case it means that the version of
"mysql-bench" that is installed on your machine blocks "mysql" from being
upgraded without breaking dependencies. The newer "mysql" is in the
repository, but the corresponding "mysql-bench" is not. Hence the upgrade
fails. Enable the full repository where Yum will find the missing
packages like mysql-bench and net-snmp-utils.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]