[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: OpenSceneGraph



Ralf Corsepius wrote:
Hi,

I've several times been asked to upgrade OpenSceneGraph to
OpenSceneGraph-2.0 (on rawhide and may-be FC7)

So far, there remain a couple of details unclear to me, I'd like to see
clarified:

* OpenSceneGraph-2.0 is completely incompatible to OpenSceneGraph-1.x!
* Packaging, features and all SONAME have changed!

Questions:
* Is there anybody out there who is actively using (esp. developing for)
OpenSceneGraph-1?

Yes. In fact I was getting ready to submit packages for the VTP from http://vterrain.org (initially including the libraries, VTBuilder and Enviro). I've contacted the author to find out what the plans for OSG-2.0 support are, and will follow up when I know more.

In addition to that, I have vtgtkmm which is a library of VTP widgets for Gtkmm (similar to the WX widgets included in libvtui from VTP).

* Is there anybody out there who is actively using Producer or who has a
package which depends on (OSG-1's) Producer (OpenSceneGraph-2 has dropped Producer).

I also have osgtkmm which is dependent upon Producer. However, a move to OSG-2.0 wouldn't bother me at all. I'd much rather target OSG-2.0 anyway.


Should you answer to any of the questions above with "yes", please speak
up ASAP.

TIA.
	Ralf




Just another side note on OSG examples... I noticed that none of the data files are included so they run without textures, etc.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]