[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: bcm43xx_mac80211 (was Re: Announcing Fedora 7 Test 4 (6.93))



On Tue, May 01, 2007 at 02:25:26PM -0700, Miles Lane wrote:
> On 5/1/07, Will Woods <wwoods redhat com> wrote:
> >Yeah, you'll want to use NetworkManager to manage the device. First you
> >will need firmware:
> >
> >1) Install bcm43xx-fwcutter
> >2) Get a Broadcom-distributed driver to cut the firmware out of
> ># See the list in /usr/share/doc/bcm43xx-fwcutter-006/README
> ># For the newer driver you'll need 4.x firmware. I recommend:
> >http://downloads.openwrt.org/sources/broadcom-wl-4.80.53.0.tar.bz2
> 
> I'll try this, but I suspect it won't work, because I have a pretty
> old bcm4306 PCI card in my desktop machine.  Last time I checked, my
> card isn't supported by the 4.x firmware.   :-(

If that is true, then you will need to stick with the older driver
(bcm43xx).

FWIW, the plan of record is for that driver (i.e. "bcm43xx") to be
renamed (probably as "bcm4301") and ported to the same new mac80211
infrastructure as the newer driver (for now "bcm43xx-mac80211",
eventually will be renamed to just "bcm43xx").  The PCI device table
of bcm4301 will also be redacted to only refer to the older devices
which require the version 3 firmware.

But, that will not probably not happen upstream in time for F7.
I would be open to making that change just for Fedora if there is
something resembling consensus that such would be better than the
current "two drivers" situation...?  Probably not worth it...?

John
-- 
John W. Linville
linville redhat com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]