[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: KDE alpha 1 packages for Fedora?



Jos Poortvliet <jos <at> mijnkamer.nl> writes:
> Dear people,In a few days KDE 4 alpha 1 will be released, and we would like
> to give as many people as possible the opportunity to have a look at the next
> generation Linux Desktop. Thus an article is being prepared to explain to
> people how they can obtain KDE 4 Alpha 1 packages. A suse livecd already
> exists, and packages will be available for Suse, Ubuntu, Debian and OS X, but
> we haven't heard from the Fedora community yet. So, as to ensure the article
> will be reasonable complete, we'd like to inquire if Fedora will have Alpha 1
> packages available to it's users.

I have parallel-installable kdelibs4, kdepimlibs4 and kdebase4 packages which 
are currently at 3.80.3 (with assorted backported bugfixes) and which I'm 
planning to upgrade to alpha 1 as soon as it's out. However, my packages are 
primarily targeted at developers, not as a sneak preview for users like the 
SuSE KDE 4 Live CD. So the focus so far has been safe parallel-installability 
with KDE 3 (so a developer can work on KDE 3 and target KDE 4), not full module 
coverage.

I think that for Fedora 8, we will want KDE 4 packaged differently, with KDE 4 
as default, all KDE 4 modules packaged and compat-kdelibs3 (and probably 
compat-kdebase3 with a subset of the current KDE 3 kdebase, e.g. the KControl 
modules which are needed by some applications) to run programs which haven't 
been ported yet. (Hopefully we won't need more compat-kde*3 stuff.) But we have 
all been busy with the TODO list for the Fedora 7 release, so we didn't have 
time to discuss this, and thus it's just my personal plan. Of course, packaging 
for Fedora 8 will not start before Fedora 7 is out, which is 3 weeks from now 
if things go well.

So I don't know of anyone working on KDE 4 packages like this. I'm sorry, but 
I'm not personally going to work on any KDE-4-as-default packages nor on any 
KDE 4 modules beyond the basic development platform (kdebase4 + dependencies) 
before Rawhide opens for Fedora 8 at the earliest. I'm already way too busy. 
IMHO, alpha 1 is too early for use as a default desktop for end users anyway. 
If you want to run (or develop) individual KDE 4 apps on a KDE 3 desktop, my 
packages are enough (I haven't packaged any such app yet though, and I probably 
won't have the time to package any any time soon); for replacing KDE 3 
altogether, it's IMHO too early, Fedora 8 is the target I suggest there (but I 
may even be overruled and the target set to Fedora 9 instead, we haven't had a 
chance to discuss this yet; it will also depend on the Fedora 8 schedule which 
AFAIK is not decided yet).

        Kevin Kofler


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]