[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F7 Zope package



David Woodhouse wrote:
On Fri, 2007-05-04 at 19:48 +0200, Thorsten Leemhuis wrote:
Jeremy Katz schrieb:
On Fri, 2007-05-04 at 10:16 -0500, David G. Mackay wrote:
It was nice to see that zope is one of the packages available for
installation in F7.  Unfortunately, the package won't work on F7
(https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=238809). The
maintainer that received the bug report suggested that I make some noise
on the devel list, so here I am.  The problem is that the zope version
packaged for F7 won't run with python 2.5.x

So? Surely it's the rĂ´le of the Fedora package maintainer to _make_ it
work with Fedora? Is the package maintainer AWOL?

I'm not AWOL and I don't think it is my job to fix upstream code.

Ok, I will state yet again; This is not a packaging issue. This is an issue of including python 2.4 support in Fedora 7 or not. Just because I am maintaining the packages, does this mean it is a requirement I work upstream to fix the many things that need to be done to even *begin* to support python 2.5? No, I am just the packager. There are *technical* reasons Zope will not run on python 2.5 and it is a lot more then it seems you think.

To try to make this more a complete discussion (even though I have already seen this posted): http://wiki.zope.org/zope3/Zope3UsingPython25

Please, I request that anyone that feels this is my fault and I am not a capable package maintain read the above... and I mean all of it. To the best of my knowledge this also shows there will never be any support for python 2.5 in the Zope 2 branch; at least not any time soon. I don't know when Plone is going to target Zope 3 but I get the feeling it is no time soon. This means that even if we get Zope 3 support in Fedora 7 using python 2.5 all the plone users will be out of luck.
Shipping Zope in Fedora 5 and Fedora 6 and excluding it in Fedora 7 just
looks so bad to out the outside and created problems for out users. I'd
really would like to avoid that.

As would I.


Yes, we should avoid getting into a situation where that can happen.
We need to make sure we have active and capable package maintainers for
the packages we ship.
I am active. Please note the current pacakges are Zope 2.9.7 and Plone 2.5.2, the most current stable/recommended versions that run on python 2.4. I promptly push out updates. Please check these things before you smear active members of the community.

Jonathan Steffan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]