[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rawhide merge status



On Monday 14 May 2007, Jerry James wrote:
> On Mon, 14 May 2007 at 15:11:38 +0200, Florian La Roche
>
> What I was trying to accomplish was splitting out related, but different
> languages, which were packaged together in earlier versions of moodle.
> (They are packaged in separate source files upstream.)  So the current
> spec file has this, for example:
>
> %package        zh_cn
> Obsoletes:      moodle-zh <= 1.6.3
> Provides:       moodle-zh = 1.6.3
>
> %package        zh_tw
> Obsoletes:      moodle-zh <= 1.6.3
> Provides:       moodle-zh = 1.6.3
>
> I thought AutoReqProv would do the right thing here, but this problem
> makes me suspect I should have written this:
>
> %package        zh_cn
> Obsoletes:      moodle-zh <= 1.6.3
> Provides:       moodle-zh = 1.6.3, moodle-zh_cn = %{version}-%{release}
>
> %package        zh_tw
> Obsoletes:      moodle-zh <= 1.6.3
> Provides:       moodle-zh = 1.6.3, moodle-zh_tw = %{version}-%{release}
>
> Would that solve the problem?

I don't think so.  Providing eg. moodle-zh_tw = %{version}-%{release} in 
itself is redundant.  One thing that you may want to have a look in the above 
is that there are self-obsoletion problems - changing those to these in both 
zh_cn and zh_tw could help (assuming %{version} is greater than or equal to 
1.6.4):

Obsoletes: moodle-zh < 1.6.4
Provides: moodle-zh = %{version}-%{release}

Or perhaps drop the Provides altogether?  See 
http://fedoraproject.org/wiki/Packaging/NamingGuidelines#head-3cfc1ea19d28975faad9d56f70a6ae55661d3c3d


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]