[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rawhide merge status



On Mon, 14 May 2007 at 19:20:06 +0300 Ville Skyttä <ville skytta iki fi>
wrote:
> I don't think so.  Providing eg. moodle-zh_tw = %{version}-%{release} in 
> itself is redundant.  One thing that you may want to have a look in the above 
> is that there are self-obsoletion problems - changing those to these in both 
> zh_cn and zh_tw could help (assuming %{version} is greater than or equal to 
> 1.6.4):
>
> Obsoletes: moodle-zh < 1.6.4
> Provides: moodle-zh = %{version}-%{release}
>
> Or perhaps drop the Provides altogether?  See 
> http://fedoraproject.org/wiki/Packaging/NamingGuidelines#head-3cfc1ea19d28975faad9d56f70a6ae55661d3c3d

I decided that dropping the Provides altogether was the best approach.
For one thing, the old language packs being obsoleted weren't the real
language packs; they only contained translations for the installation
code.  For another, they were in the wrong place, so they didn't work
anyway.  Hence, it is unlikely that anybody actually used them.

Thanks, Ville.
-- 
Jerry James, Assistant Professor        Jerry James usu edu
Computer Science Department             http://www.cs.usu.edu/~jerry/
Utah State University


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]