[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Wireless Testing Needed for F7



On 5/15/07, Tom London <selinux gmail com> wrote:
On 5/15/07, Andrew Bartlett <abartlet samba org> wrote:
> On Tue, 2007-05-15 at 19:22 -0500, Dennis Gilmore wrote:
> > Once upon a time Monday 14 May 2007, Warren Togami wrote:
> > > https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=238657
> > > We are attempting to get wireless working on x86_64.
> >
> > > http://kojiweb.fedoraproject.org/packages/wireless-tools/28/3.fc7/
> > > If you use wireless on ANY arch of rawhide, please test this latest
> > > wireless-tools build.  We need to be sure that the x86_64 fix doesn't
> > > break i386 or ppc*.
> > >
> > > Please report in the above bug if release -3 is any better or worse than
> > > release -1 or -2.
> > >
> > > We really would like to confirm this before the proposed F7 final freeze
> > > on Thursday.
> > >
> > > Warren Togami
> > > wtogami redhat com
> >
> > wireless started working for me with this wireless-tools package.  i'm on a
> > Dell Latitude D820 x86_64 with iwl3945 driver
>
> For me, on an Lenovo X60 (x86) with the iwl3945 driver, on the current
> rawhide kernel (2.6.21-1.3149.fc7) and 28-3 release of the wireless tool
> this works until NetworkManager does a rescan.
>
> This is pretty much in line with what I've been seeing for quite a while
> over various kernels now (I've never had it work any more than this
> much, and often worse).
>
> Andrew Bartlett
>
Same hardware, same results...  I get about 15 seconds worth of
traffic through before it 'stops working'.

Get lots of these (don't remember getting these before):

wlan0: CTS protection disabled (BSSID=00:14:6a:5b:3a:80)
printk: 18 messages suppressed.
wlan0: CTS protection enabled (BSSID=00:14:6a:5b:3a:80)
printk: 17 messages suppressed.
wlan0: CTS protection enabled (BSSID=00:14:6a:5b:3a:80)
printk: 20 messages suppressed.
wlan0: CTS protection disabled (BSSID=00:14:6a:5b:3a:80)

This seems more complicated....

With above hardware/system (Thinkpad X60, NetworkManager, ...), if I
connect to a 'very close' AP (i.e., Linksys WRT54G, less than 3 feet
away), system stays connected and is rock solid.

The above unstable situation is ('@work') where there are multiple APs
for the same SSID, and I'm (much) further away, so the link quality is
not as good.

Here is the output from 'iwlist wlan0 scan' when connected to the very
close AP.  I believe the 'Quality' numbers are not correct:

         Cell 01 - Address: 00:12:17:46:42:51
                   ESSID:"free4all"
                   Mode:Master
                   Channel:10
                   Frequency:2.457 GHz
                   Quality=92/100  Signal level=-35 dBm
                   Encryption key:on
                   IE: WPA Version 1
                       Group Cipher : TKIP
                       Pairwise Ciphers (2) : CCMP TKIP
                       Authentication Suites (1) : PSK
                   IE: IEEE 802.11i/WPA2 Version 1
                       Group Cipher : TKIP
                       Pairwise Ciphers (2) : CCMP TKIP
                       Authentication Suites (1) : PSK
                   Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                             24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                             12 Mb/s; 48 Mb/s
                   Extra:tsf=0000008d40a4e6be
                   Extra:bcn_int=100
                   Extra:capab=0x0431
         Cell 02 - Address: 00:0D:97:04:0C:BE
                   ESSID:"GoogleWiFi"
                   Mode:Master
                   Channel:9
                   Frequency:2.452 GHz
                   Quality=95/100  Signal level=-71 dBm
                   Encryption key:off
                   Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                             11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                             48 Mb/s; 54 Mb/s
                   Extra:tsf=000000619d91557c
                   Extra:bcn_int=250
                   Extra:capab=0x0001

Running from  '@work' (multiple APs, multiple networks), network
'disassociates' quickly.

I attach output from dmesg.

tom
--
Tom London
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: RX authentication from 00:14:6a:5b:3a:80 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:14:6a:5b:3a:80
wlan0: authentication frame received from 00:14:6a:5b:3a:80, but not in authenticate state - ignored
wlan0: RX AssocResp from 00:14:6a:5b:3a:80 (capab=0x431 status=0 aid=143)
wlan0: associated
wlan0: WMM queue=2 aci=0 acm=0 aifs=3 cWmin=15 cWmax=1023 burst=0
wlan0: WMM queue=3 aci=1 acm=0 aifs=7 cWmin=15 cWmax=1023 burst=0
wlan0: WMM queue=1 aci=2 acm=0 aifs=2 cWmin=7 cWmax=15 burst=30
wlan0: WMM queue=0 aci=3 acm=0 aifs=2 cWmin=3 cWmax=7 burst=15
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
iwl3945: REPLY_ADD_STA failed
wlan0: association frame received from 00:14:6a:5b:3a:80, but not in associate state - ignored
iwl3945: REPLY_ADD_STA failed
hwcrypto disabled!
hwcrypto disabled!
hwcrypto disabled!
hwcrypto disabled!
wlan0: no IPv6 routers present
wlan0: no IPv6 routers present
wlan0: No ProbeResp from current AP 00:14:6a:5b:3a:80 - assume out of range
hwcrypto disabled!
wlan0: No STA entry for own AP 00:14:6a:5b:3a:80
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: authentication with AP 00:14:6a:5b:3a:80 timed out
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: RX deauthentication from 00:14:6a:5b:3a:80 (reason=2)
wlan0: deauthenticated
wlan0: RX deauthentication from 00:14:6a:5b:3a:80 (reason=2)
wlan0: RX deauthentication from 00:14:6a:5b:3a:80 (reason=2)
wlan0: RX deauthentication from 00:14:6a:5b:3a:80 (reason=2)
wlan0: RX deauthentication from 00:14:6a:5b:3a:80 (reason=2)
wlan0: RX deauthentication from 00:14:6a:5b:3a:80 (reason=2)
wlan0: RX deauthentication from 00:14:6a:5b:3a:80 (reason=2)
wlan0: RX deauthentication from 00:14:6a:5b:3a:80 (reason=2)
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: authentication with AP 00:14:6a:5b:3a:80 timed out
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: authentication with AP 00:14:6a:5b:3a:80 timed out
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: authentication with AP 00:14:6a:5b:3a:80 timed out
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: authentication with AP 00:14:6a:5b:3a:80 timed out
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:16:c8:9b:7d:60
wlan0: authenticate with AP 00:16:c8:9b:7d:60
wlan0: authenticate with AP 00:16:c8:9b:7d:60
wlan0: authentication with AP 00:16:c8:9b:7d:60 timed out
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:16:c8:9b:7d:60
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:16:c8:9b:7d:60
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: RX authentication from 00:14:6a:5b:3a:80 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:14:6a:5b:3a:80
wlan0: authentication frame received from 00:14:6a:5b:3a:80, but not in authenticate state - ignored
wlan0: authentication frame received from 00:14:6a:5b:3a:80, but not in authenticate state - ignored
wlan0: authentication frame received from 00:14:6a:5b:3a:80, but not in authenticate state - ignored
wlan0: authentication frame received from 00:14:6a:5b:3a:80, but not in authenticate state - ignored
wlan0: authentication frame received from 00:14:6a:5b:3a:80, but not in authenticate state - ignored
wlan0: RX ReassocResp from 00:14:6a:5b:3a:80 (capab=0x431 status=0 aid=169)
wlan0: associated
wlan0: WMM queue=2 aci=0 acm=0 aifs=3 cWmin=15 cWmax=1023 burst=0
wlan0: WMM queue=3 aci=1 acm=0 aifs=7 cWmin=15 cWmax=1023 burst=0
wlan0: WMM queue=1 aci=2 acm=0 aifs=2 cWmin=7 cWmax=15 burst=30
wlan0: WMM queue=0 aci=3 acm=0 aifs=2 cWmin=3 cWmax=7 burst=15
wlan0: association frame received from 00:14:6a:5b:3a:80, but not in associate state - ignored
iwl3945: REPLY_ADD_STA failed
iwl3945: REPLY_ADD_STA failed
wlan0: RX WEP frame with unknown keyidx 1 (A1=ff:ff:ff:ff:ff:ff A2=00:14:6a:5b:3a:80 A3=00:00:74:ad:43:b1)
wlan0: RX deauthentication from 00:14:6a:5b:3a:80 (reason=2)
wlan0: deauthenticated
wlan0: RX WEP frame with unknown keyidx 1 (A1=ff:ff:ff:ff:ff:ff A2=00:14:6a:5b:3a:80 A3=00:c0:b7:7f:67:8a)
wlan0: RX WEP frame with unknown keyidx 1 (A1=ff:ff:ff:ff:ff:ff A2=00:14:6a:5b:3a:80 A3=00:0d:56:bc:0e:d0)
wlan0: RX WEP frame with unknown keyidx 1 (A1=ff:ff:ff:ff:ff:ff A2=00:14:6a:5b:3a:80 A3=00:30:48:43:86:f4)
wlan0: RX WEP frame with unknown keyidx 1 (A1=01:80:c2:00:00:00 A2=00:14:6a:5b:3a:80 A3=00:04:80:c9:54:2f)
wlan0: RX WEP frame with unknown keyidx 1 (A1=01:80:c2:00:00:00 A2=00:14:6a:5b:3a:80 A3=00:04:80:c9:54:2f)
wlan0: RX WEP frame with unknown keyidx 1 (A1=ff:ff:ff:ff:ff:ff A2=00:14:6a:5b:3a:80 A3=00:00:74:ad:43:b1)
wlan0: authenticate with AP 00:14:6a:5b:3a:80
wlan0: RX authentication from 00:14:6a:5b:3a:80 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:14:6a:5b:3a:80
wlan0: RX ReassocResp from 00:14:6a:5b:3a:80 (capab=0x431 status=0 aid=170)
wlan0: associated
iwl3945: REPLY_ADD_STA failed
iwl3945: REPLY_ADD_STA failed
wlan0: disassociate(reason=3)
iwl3945: check mac addr 1 | 1
iwl3945: check basic rate 2 | 1
iwl3945: check assoc id 3 | 1
iwl3945: check CCK and short slot 4 | 1
iwl3945: check CCK & auto detect 5 | 1
iwl3945: check TGG 6 | 1
iwl3945: check antenna 7 1
iwl3945: Tuning to channel 2
iwl3945: Error not a valid ipw_rxon_assoc_cmd field values
iwl3945: Invalid RXON configuration.  Not committing.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]