[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Conflict in /usr/lib/kde3/plugins/styles/keramik.so:



Am Donnerstag, 17. Mai 2007 schrieb Rex Dieter:
> Neal Becker wrote:
> > I ran this on current fc7test with all updates, on x86_64:
> >
> > kdiff3 idma-cdma idma-cdma.nbecker4
> > Conflict in /usr/lib/kde3/plugins/styles/keramik.so:
> >   Plugin uses incompatible Qt library!
> >   expected build key "x86_64 Linux g++-4.* full-config", got "i686 Linux
> >   g++-4.* full-config".
> >
> > What does this mean?
> >
> > BTW, I'm the kdiff3 maintainer, so maybe I need to do something?
>
> Funky wierd.
>
> it's 99% *not* kdiff3 at play here, it appears to be a multilib thing.
>
> I'd assume other kde apps would give the same warning/error, do they?  If
> so, bugzilla it against kdelibs.
>

It's a multilib problem on your machine. the problem is that you are using the 
Qt, build for x86_64, and kde plugins (in your case, keramik.so), built for 
i688. I caused this conflict. 
removing /usr/lib64/qt-3.3/etc/settings/qt_plugins_3.3rc and 
~/.qt/qt_plugins_3.3rc should perhaps fix the problem.

Than


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]