[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: RFC: Fedora 8 and KDE 4



Jeremy Katz <katzj <at> redhat.com> writes:
> > I hate -devel conflicts too, but the at least the .so symlinks conflict,
> Then things *aren't* parallel installable.

A lot of compat libs work like that, the runtime packages with the versioned 
so-s are parallel installable, the -devel packages conflict.

This is also what upstream KDE is planning to deliver.

> Conflicts like this just aren't acceptable to have in Fedora because now
> _I_ as a developer have to choose which I'm developing apps for.  And if

Guess why I hate them too.
There's the possibility of switching between the packages or of using a mock 
chroot, but that sucks.

> I'm just building apps that I find online, I'm going to be wanting to
> build for both APIs.

Same as above.

> And that makes our user experience suck.  If upstream doesn't see that,
> then it might be worth doing like we've had to do for some other
> libraries to get fully parallel installable even if it's not the path of
> upstream :(

Sure I could patch the heck out of KDE to install the symlinks 
into /usr/lib/kde[34], rename conflicting binaries etc., but then we'd probably 
have to patch the heck out of all applications building against it. KDE doesn't 
use pkg-config, and kde-config has no --libs option where you can easily add 
a -L foo option. And this doesn't even cover stuff like kconfig_compiler.

Or we could install one of the 2 KDE versions into a custom prefix 
like /opt/kde3 or /opt/kde4, and in fact this is what my current kde*4 packages  
do, but then good bye FHS.

> But one would hope that when presented with reason and
> patches, upstream would be willing to come along.  Because every other
> distribution is going to have the same questions, concerns and problems

Rex Dieter, I think you have the best contacts upstream, could you please take 
this up with them?

But I'm not sure about the "every other distribution" part. OpenSUSE had KDE 3 
in /opt/kde3, so they're not affected by most of this, and the others probably 
just have the -devel packages conflict.

         Kevin Kofler


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]