[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: iwl3945 status in fedora7



On 5/24/07, Andy Green <andy warmcat com> wrote:
Lamont Peterson wrote:

> I have a co-worker with an IPW3945 in his ThinkPad and a couple of other
> friends who have the IPW3945 in their notbooks.  They have all reported that
> they can not use NetworkManager with it.  Apparently, it's a well known
> problem that NetworkManager doesn't play (at all?) nicely with IPW3945 cards
> using either the older daemon or the newer drivers.
>
> I haven't heard reports yet in testing with F7 on their notebooks, but I know
> at least one of them was doing so.  If there is any new info regarding those
> tests, I'll try to post it here.

For me, using 2.6.21-1.3194.fc7, NM scans and finds networks okay, but
does not succeed to associate with the WPA2 network here even when given
the correct pre-shared key for all the variations of encryption protocol.

Stopping NetworkManager and the nm-applet, re-modprobing the module and
restarting wpa_supplicant associates and works.

-Andy

Seems a bit more complicated that this for me (with .3194): When I am
very close to an AP (e.g., 3 feet) I have no problem with iwl3945 and
NetworkManager.  However, if I am in a 2 AP setup (i.e., 2
approximately equal signal strength APs with the same SSID),
NetworkManager succeeds in initially associating, but immediately
(e.g., within 30 seconds, sometimes as fast as 5 seconds) borks when
trying to reassociate.

Here is a snippet from /var/log/messages.  Notice that I am associated
with AP 00:14:6a:5b:3a:80 when this occurs (and it tries to associate
with AP 00:14:69:3b:af:60 and gets confused.....):

May 24 09:33:15 localhost dnsmasq[2954]: using nameserver 10.10.2.11#53
May 24 09:33:15 localhost dnsmasq[2954]: using nameserver 10.10.2.102#53
May 24 09:33:21 localhost kernel: wlan0: RX too short data frame payload
May 24 09:33:21 localhost last message repeated 3 times
May 24 09:33:23 localhost kernel: iwl3945: REPLY_ADD_STA failed
May 24 09:33:23 localhost wpa_supplicant[3686]: Trying to associate
with 00:14:69:3b:af:60 (SSID='INSIDE' freq=2422 MHz)
May 24 09:33:23 localhost kernel: wlan0: Initial auth_alg=0
May 24 09:33:23 localhost kernel: wlan0: authenticate with AP 00:14:6a:5b:3a:80
May 24 09:33:23 localhost kernel: wlan0: Initial auth_alg=0
May 24 09:33:23 localhost kernel: wlan0: authenticate with AP 00:14:69:3b:af:60
May 24 09:33:23 localhost kernel: iwl3945: REPLY_ADD_STA failed
May 24 09:33:23 localhost kernel: wlan0: Initial auth_alg=0

tom
--
Tom London


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]