[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: iwl3945 status in fedora7



I've now managed to get past my problem with the Hardware Kill Swicth (see earlier threads).

After a "setkeycodes e004 147" I am able to use Fn-F2 to disable the kill switch.
Still not sure how to do this permanently though.

With kernel-2.6.21-1.3189.fc7 I can then modprobe iwl3945 and I actually do get an wlan0 interface, but I do get some errors:

iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 0.0.16kd
iwl3945: Copyright(c) 2003-2007 Intel Corporation
ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 16 (level, low) -> IRQ 19
PCI: Setting latency timer of device 0000:02:00.0 to 64
iwl3945: Detected Intel PRO/Wireless 3945ABG Network Connection
iwl3945: Channel 14 [2.4GHz] is Tx only -- skipping.
iwl3945: Channel 183 [5.2GHz] is Tx only -- skipping.
iwl3945: Channel 184 [5.2GHz] is Tx only -- skipping.
iwl3945: Channel 185 [5.2GHz] is Tx only -- skipping.
iwl3945: Channel 187 [5.2GHz] is Tx only -- skipping.
iwl3945: Channel 188 [5.2GHz] is Tx only -- skipping.
iwl3945: Channel 189 [5.2GHz] is Tx only -- skipping.
iwl3945: Channel 192 [5.2GHz] is Tx only -- skipping.
iwl3945: Channel 196 [5.2GHz] is Tx only -- skipping.
iwl3945: Channel 7 [5.2GHz] is Tx only -- skipping.
iwl3945: Channel 8 [5.2GHz] is Tx only -- skipping.
iwl3945: Channel 11 [5.2GHz] is Tx only -- skipping.
iwl3945: Channel 12 [5.2GHz] is Tx only -- skipping.
iwl3945: Channel 16 [5.2GHz] is Tx only -- skipping.
iwl3945: Channel 145 [5.2GHz] is Tx only -- skipping.
iwl3945: Channel 149 [5.2GHz] is Tx only -- skipping.
iwl3945: Channel 153 [5.2GHz] is Tx only -- skipping.
iwl3945: Channel 157 [5.2GHz] is Tx only -- skipping.
iwl3945: Channel 161 [5.2GHz] is Tx only -- skipping.
iwl3945: Channel 165 [5.2GHz] is Tx only -- skipping.
iwl3945: Tunable channels: 13 802.11bg, 23 802.11a channels
wmaster0: Selected rate control algorithm 'iwl-3945-rs'
iwl3945: Error sending POWER_TABLE_CMD: time out after 500ms.
iwl3945: Error sending POWER_TABLE_CMD: time out after 500ms.
iwl3945: Error sending BT_CONFIG: time out after 500ms.
iwl3945: Error sending RXON: time out after 500ms.
iwl3945: Error setting new configuration (-110).
hwcrypto disabled!
hwcrypto disabled!

And I am not able to get the interface up:

# ifconfig wlan0 up
SIOCSIFFLAGS: Input/output error



With kernel-2.6.21-1.3194.fc7 I do not get any error messages (I get the same "channel FOO is tx only" but I guess that is not a problem), but the interface wlan0 does not show up at all.
- Only eth0 and lo is available even with ifconfig -a

Thanks for the hard work.

--
        _,--',   _._.--._____
 .--.--';_'-.', ";_      _.,-'   Ola Thoresen
.'--'.  _.'    {`'-;_ .-.>.'
      '-:_      )  / `' '=.      It is easier to fix Unix
        ) >     {_/,     /~)     than to live with Windows
        |/               `^ .'



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]