[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: java-plugin not working in F8



Valent Turkovic wrote:
On Nov 9, 2007 12:57 PM, Mike A. Harris <mharris mharris ca> wrote:
Mike Chambers wrote:
On Fri, 2007-11-09 at 11:44 +0100, Valent Turkovic wrote:
Hi,

I installed java plugin via 'yum install java-plugin' and firefox
still complains that plugin is not installed...
I'm running 32bit fedora (I saw previous mails regarding F7 on 64bit).
Just install the java-icedtea-plugin (just look for icedtea) from Fedora
and it will work just fine.

Otherwise, maybe you need to create a link to /usr/lib/mozilla/plugins
as well?
I'm running F8/x86_64 and haven't manually installed any Java stuff yet,
just whatever might have been installed by anaconda by default.  Up
until now I hadn't visited any web pages with Java on them.

A lot of people have been having problems with Java it seems, and so I
decided to try to get it to work myself.  I google searched for a "Java
test", went to the Sun page, and it just worked automatically already,
presumeably with iced-tea, which I assume was installed for me already
by anaconda.  I went to a variety of other Java websites to test it out
and have had no problems at all so far.  All Java sites work in firefox
for me automatically.

As mentioned above, I haven't had to install anything, configure
anything, or do anything manual for this to work, it just works out of
the box on x86_64, at least for me.

I can only assume that the people having the problems either:

1) Are coming from an upgrade of a previous OS release
or
2) Have Sun, IBM, or some other Java installed already, or are trying to
install some other Java
3) Have upgraded and didn't get iced-tea by default perhaps.

Anyhow, worst case scenario -> do a fresh OS install and Java seems to
work in firefox right out of the box.  ;o)

I only installed java-plugin, I already had java installed
out-of-the-box in this fresh Fedora 8 Gnome Live CD install.

I don't have anything called "java-plugin" installed, but Java seems to be working fine:

pts/7 mharris hammer:~$ rpm -q java-plugin
package java-plugin is not installed


I tested one java page prior to installing java-plugin and it said
that java wasn't installed, after instalation of java-plugin I now
tested it again with following pages:
http://www.javatester.org/
http://www.java.com/en/download/help/testvm.xml

and both say I don't have java plugin installed.

Both of those pages work for me and correctly detect "Java 1.7.0 from Sun Microsystems". Again, note that I did not install Sun Java, so this message is coming from iced-tea presumeably. Here's a query of my system showing what packages containing 'java' in the name that are installed:

pts/7 mharris hammer:~$ rpm -qa | grep java | sort
glib-java-0.2.6-8.fc7
java-1.5.0-gcj-1.5.0.0-17.fc8
java-1.7.0-icedtea-1.7.0.0-0.19.b21.snapshot.fc8
java-1.7.0-icedtea-plugin-1.7.0.0-0.19.b21.snapshot.fc8
java_cup-0.10-0.k.6jpp.1
tzdata-java-2007i-1.fc8


Any other ideas?

If you have any proprietary Java packages installed, remove them, and if you are missing any of the above packages, install them. Then restart firefox, or reboot.


--
Mike A. Harris

Come and join us on the #fedora8 IRC help forum on irc.freenode.net


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]