[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: XULRunner in rawhide



Martin Stransky wrote:
Hello,

there's a new package in rawhide, xulrunner
(xulrunner-1.9-0.alpha9.3.fc9). This package is supposed to provide
gecko-libs instead of Firefox and the plan is to ship Firefox as a pure
XUL application and run in by xulrunner.

So no more firefox-devel packages in rawhide, you should use
xulrunner-devel (gecko-libs == 1.9) now.

If you maintain any package what is built against gecko-libs (or
firefox-devel), please rebuild it with the xulrunner. The xulrunner-*.pc
pkg-config files are provided and you may add "--with-gecko=xulrunner"
directive to configure script.

Actually, this is not going to work for many apps if it works at all. They would need some porting. I haven't had time to write up some info on this yet, though.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]